Skip to main content
Topic: Can't get past "Writable Check" during installation. (Read 153 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Can't get past "Writable Check" during installation.

Hello everyone! I'm trying to set up Elkarte for the first time and I'm having some trouble with the installer. It seems to think that all the Elkarte files are write-protected, but this is not the case according to ls. I've tried setting up an FTP server and filling in the details at the bottom of the page to let it auto-fix whatever the problem is, but when I click "Connect" it just refreshes the page. I'm running it in a VM with nginx, PHP 7.3, and MariaDB 5.5.65 on CentOS 7 (didn't realize they'd already come out with 8 until after I installed it). The host OS is Manjaro Linux, and the hypervisor is QEMU/KVM. Any ideas guys?

Spoiler (click to show/hide)

Re: Can't get past "Writable Check" during installation.

Reply #1
So you're saying all the listed files/directories are 755 or 777? On some systems, for whatever reason, 777 is necessary for file write permissions. In theory 755 should be sufficient, yet isn't. Try going 777.

Another possibility is file ownership. Hope that helps!

Re: Can't get past "Writable Check" during installation.

Reply #2
That's what it said on the page, so I set all the files to 777 (you can tell because ls -l shows rwxrwxrwx for all of them in the spoiler) and it still has this problem. Currently the owner is my nginx user; I'll try setting it to myself.

Re: Can't get past "Writable Check" during installation.

Reply #3
Nope, still not working. Is there some kind of log I can check for more details?

Re: Can't get past "Writable Check" during installation.

Reply #4
Nginx is probably not the correct owner. PHP accesses those files. It should be the same owner PHP would use under the VM container, I think.

Re: Can't get past "Writable Check" during installation.

Reply #5
Okay this is weird. So I'm running nginx and PHP-FPM via systemd's systemctl, so according to htop the master processes are running as root but all the others are running as the nginx user. :/