Skip to main content
Topic: Likes and Quickbuttons dont work (Read 1461 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: Likes and Quickbuttons dont work

Reply #30

I have figured this out ... Now I just need to come up with the fix :innocent:

Re: Likes and Quickbuttons dont work

Reply #31

Glad to hear you found the problem, I wasn't able to replicate this bug, but I admit I did not read all the topic.
sorry for my bad english

Re: Likes and Quickbuttons dont work

Reply #32

The short of what I believe was occurring had to do with the quick reply area being minimized when "quote" was selected, causing a Javascript error.  This should be fixed now (refresh required)

When I updated the Quick Reply in 2.0, I neglected / improperly defined that minimize function.  In Ruth's case, she had minimized the Quick Reply section at some point  The system remembers that choice (it is not a profile option, it simply remembers your "hide/show" choice).  So hitting quote with the box minimized failed.

Now part B.  The original (inherited) behavior is, should the Quick Reply section be minimized then clicking "quote" would take you to the full page editor (the one where you can add attachments etc.).  Basically if QR was minimized it was "off" and if you wanted to use it, scroll down, expand, enter a response and maybe scroll back up to grab a quote.  I'm going to assume this was not a well know option/behavior.

As an experiment, I've changed that behavior to instead
- expand the Quick Reply area (assuming its minimized)
- insert the quote. 
- scroll it into view.

This is the same behavior you have when the Quick Reply is not minimized.  Note this does not change your hide/show preference, that will only change by you clicking on the expand/collapse icon.

Any thoughts on how the system should respond in the case where QR is minimized?  Auto expand and insert or bypass and jump to the full page post screen?

Re: Likes and Quickbuttons dont work

Reply #33

Quick edit and quote - both works again now for me, Spuds... great. :)

Quote from: Spuds – Any thoughts on how the system should respond in the case where QR is minimized?  Auto expand and insert or bypass and jump to the full page post screen?

I would prefer to have it in the full post screen.

But i dont like the quick reply very much anyway. I mostly have it minimized.

Re: Likes and Quickbuttons dont work

Reply #34

Ah, so I was correct. (I said it could be anything, and as it turned out, it was..)

I didn't even notice that QR could be minimized, the up/down chevron for that is pretty faint and, since I've used my eyes intensely all my life they're pretty worn out now, so apparently I just didn't notice it..

Very good, Spuds..

// Deep inside every dilemma lies a solution that involves explosives //

Re: Likes and Quickbuttons dont work

Reply #35

Quote from: Spuds – Any thoughts on how the system should respond in the case where QR is minimized?  Auto expand and insert or bypass and jump to the full page post screen?

I'd just say have it auto-expand the QR.
If people want to multi-quote, going to full page post will make that difficult.

Re: Likes and Quickbuttons dont work

Reply #36

Yes, thats true....

The changings Spuds made now, had also another effect for me:

I can see again, who sent me private messages some years ago.  :smiley:
All user names had been gone before in my private messages, now they are there again.

Re: Likes and Quickbuttons dont work

Reply #37

Can it be this bug is in 1.1.9 as well?

One of my members informed me he can't give likes in certain boards, while I still can. Can't figure out whats happening.  :embarrassed:

Re: Likes and Quickbuttons dont work

Reply #38

Quote from: Jorin – he can't give likes in certain boards, while I still can. Can't figure out whats happening.
I'd say it's a permission thing, did you checked the permissions on that board?
sorry for my bad english

Re: Likes and Quickbuttons dont work

Reply #39

The board where he can't give likes (he actually don't see given likes there too) has standard permissions like most of my boards. The user profile is pretty standard too, nothing special.

Re: Likes and Quickbuttons dont work

Reply #40

I don't think is the case, I had a user who reported that he cannot give likes, I checked 10 times all the permissions and in the end I discovered that he wanted to like his own post. :cheesy:
Like I said, I hope is not the case
sorry for my bad english

Re: Likes and Quickbuttons dont work

Reply #41

Yes, Radu....lol

But i think, if a user cannot see given likes as well in a topic, it has not to do with permissions/settings in this board. He would see the given likes then.

Jorin, you wrote "board", not "topics". You did not mean the like stats in the boards, you mean the likes in the topics?

Re: Likes and Quickbuttons dont work

Reply #42

Quote from: Jorin – Can it be this bug is in 1.1.9 as well?
The likes issue was unique to 2.0 (due to the HTML markup changes).  Also the Quick Reply issue (when it was collapsed) was only a 2.0 issue, due to the new QR markup.

1.1.9 did make some changes to the likes markup, I outlined that here: https://www.elkarte.net/community/index.php?topic=6204.0  That change was to avoid ad blockers from disabling the like button.

Strange that your user is only seeing the issue on a specific board.  The like logic to allow using them is

0) the function is enabled
1) they have like permission
2) the topic is not locked
3) its not their post (if not allowed to like their own posts)
4) they are above the like post count to allow likes

They may see the counter if the post has like, even if they can't like the post for the above reasons.