Skip to main content
Topic: Attachment Drag and Drop Failed (Read 827 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Attachment Drag and Drop Failed

Tried to add one attachment to a thread and it failed. Attachments of errors attached ... I hope.

ETA: OK fine, it worked here. This is the thread for the first attempt

http://www.elkarte.net/community/index.php?topic=1474.msg10158#msg10158

Sequence of events are that I replyed to a post and posted the reply. Forgot to add the attachment, then modified the post and drag/drop the attachment, saved the edit and got the "an error has occured". When back, added the attachment again, saved and then got the Modify message error.

From the message in the Modify error, I do wonder if the image was attempted to be placed in the thread that I had listed as a URL?


Re: Attachment Drag and Drop Failed

Reply #2
Quickly posting for reference (I have to go bed **now**! LOL)

Code: [Select]
Database error, given array of integer values is empty. (not_id_attach)
Function: removeAttachments
File: /[...]/sources/subs/ManageAttachments.subs.php
Line: 187
The 'attach_del' is triggered (probably because of some concurrence between D&D upload and the normal form), but if there are no attachments to **keep** the query fails.

Fixed with a trick:
https://github.com/emanuele45/Dialogo/commit/9cac20b5d824ae6ef96704e7252bfa7702f47963
The proper fix is a proper handling of the removal of the attachments. 1.1

ETA: fix applied here as well.
Bugs creator.
Features destroyer.
Template killer.