Skip to main content
Topic: Shoutbox and Custom Blocks in Portal (Read 1458 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Shoutbox and Custom Blocks in Portal

There are a few problems with the shoutbox...difficult to explain for me, but I will try it.

1.
The shoutbox-block cannot be placed in the blocklist, where it should be. It looks like the correct order of blocks, if I watch the blocklist, but if I look at the portal, the shoutbox is somewhere else. I have to move the shoutbox-block again in portal. Any other Admin has to do this again for her account.

2.
It is the same with any custom block in portal - if you are admin. You have to move the blocks in portal to get the correct order of blocks. First they are not at the same place as shown on the blocklist.

3.
 If a member, wich is not admin (or wich is not me, I am not sure about this), is going to make a shout in shoutbox, the refresh of shoutbox is getting very slow, the new shouts are not shown at all until the portal or the forum had been refreshed. After such a shout from another account, it is the same for me (or for admins), it is no longer possible to make shouts for anybody.

4. I cannot "prune" the shouts in shoubox. If I try this, the shoutbox will be completely deleted. Also the shoutbox-block does no longer exist.


All this happend severel times, before the patch and today again. The shoutbox is working perfect - but only for me. ;)

Re: Shoutbox and Custom Blocks in Portal

Reply #1
Remember that users can arrange their blocks however they want.

What you see in the admin panel is only for new users or users that have not arranged the blocks as they like.

You can tell if you have a custom block arrangement if you see the red reset button on the portal page, clicking that will "reset" the layout to the default.

I'll check the shoutbox to see if I can find any problems.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Shoutbox and Custom Blocks in Portal

Reply #2
1.
The shoutbox-block cannot be placed in the blocklist, where it should be. It looks like the correct order of blocks, if I watch the blocklist, but if I look at the portal, the shoutbox is somewhere else. I have to move the shoutbox-block again in portal. Any other Admin has to do this again for her account.

2.
It is the same with any custom block in portal - if you are admin. You have to move the blocks in portal to get the correct order of blocks. First they are not at the same place as shown on the blocklist.
See previous question / discussion
3.
 If a member, wich is not admin (or wich is not me, I am not sure about this), is going to make a shout in shoutbox, the refresh of shoutbox is getting very slow, the new shouts are not shown at all until the portal or the forum had been refreshed. After such a shout from another account, it is the same for me (or for admins), it is no longer possible to make shouts for anybody.
Have not been able to reproduce this .  What value do you have set for the refresh time in the shoutbox settings?
4. I cannot "prune" the shouts in shoubox. If I try this, the shoutbox will be completely deleted. Also the shoutbox-block does no longer exist.
This was a bug, the prune link calls the delete function  :-*  its fixed now
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Shoutbox and Custom Blocks in Portal

Reply #3
Remember that users can arrange their blocks however they want.

Thank you very much, Spuds! I did not notice this before, :-[  because I was always used to have the  side collapsing disabled. So I did never see the red reset button before.

I hope, that my members could manage the arrangement of blocks themselves...most of them are very old people and new things are sometimes not easy to do for them.  ;) It is the same for me... :D

Quote
What value do you have set for the refresh time in the shoutbox settings?

10 seconds...and this is working, I can see it.

If you click on the shout-Button, this "refresh-arrow" gets very slow and nothing happens. New shouts are not shown until you make a refresh oft the portal or the forum - or if you change from portal to forum.

The shoutbox was working quite well, while I was the only person online. I am using three accounts at the moment and I could chat with myself without any problems.  ;) Now two of my friends have registerd and the shoutbox don't work. The first shout from another person than me will slow the shoutbox down for every account.

I have deleted the shoutbox a few times and created new ones. Any time the new shoutbox is working perfect - until another person is going to write in it. It is really strange...

Re: Shoutbox and Custom Blocks in Portal

Reply #4
There is another thing about the shoutbox:

Team-Members (Global Moderators) should be able to delete shouts in the shoutbox. Deleting shouts is working, if they have the permission to aministrate the shoutbox. But now they see the admin-button in Forum, wich they don't need to see, because they can nothing do there without any other permissions in the admin panel.

They cannot see the shoutbox inside the admin panel for example to prune shouts.

Re: Shoutbox and Custom Blocks in Portal

Reply #5
Thank you very much, Spuds! I did not notice this before, :-[  because I was always used to have the  side collapsing disabled. So I did never see the red reset button before.
Thats another bug, the reset should be there even with side collapsing disabled.
10 seconds...and this is working, I can see it.

If you click on the shout-Button, this "refresh-arrow" gets very slow and nothing happens. New shouts are not shown until you make a refresh oft the portal or the forum - or if you change from portal to forum.

The shoutbox was working quite well, while I was the only person online. I am using three accounts at the moment and I could chat with myself without any problems.  ;) Now two of my friends have registerd and the shoutbox don't work. The first shout from another person than me will slow the shoutbox down for every account.

I have deleted the shoutbox a few times and created new ones. Any time the new shoutbox is working perfect - until another person is going to write in it. It is really strange...
That is strange, I'll keep working to see if I can figure out what may cause such a thing.

There is another thing about the shoutbox:

Team-Members (Global Moderators) should be able to delete shouts in the shoutbox. Deleting shouts is working, if they have the permission to aministrate the shoutbox. But now they see the admin-button in Forum, wich they don't need to see, because they can nothing do there without any other permissions in the admin panel.

They cannot see the shoutbox inside the admin panel for example to prune shouts.
Make sure you are not giving them "Manage Shoutbox" permissions The one under members -> permissions -> general -> groupname .

To allow them to delete shouts, all you need is in Shoutbox Settings,  select the group(s) as one of the Moderation groups for that shoutbox.  All that is on the same page where you set the refresh time above.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Shoutbox and Custom Blocks in Portal

Reply #6

Make sure you are not giving them "Manage Shoutbox" permissions The one under members -> permissions -> general -> groupname .

To allow them to delete shouts, all you need is in Shoutbox Settings,  select the group(s) as one of the Moderation groups for that shoutbox.  All that is on the same page where you set the refresh time above.

I did it that way, Spuds.

Sorry, I was wrong with this :-*  I only thought, that they can see the adminbutton, because they are allowed to delete shouts.

But they see the adminbutton, because they have the permission to edit the newsfader in forum.  :D Sorry.

Re: Shoutbox and Custom Blocks in Portal

Reply #7
Today I deinstalled the patch and the portal and installed the patch and the newest version of the portal again.
Step by step I created the blocks in portal... always testing the shoutbox by doing this.

Nobody is online to make shouts, except me, but this time the shoutbox began already to get slow for me.
It happend because I changed from portal to forum and back to portal. It was not possible to write in the shoutbox after that.

So I deleted the shoutbox again and created a new one. The new shoutbox is now only displayed in portal.

Maybe the mistake depends on using the advanced opinions for the shoutbox, so that it was displayed in portal and forum?

At the moment the shoutbox in portal is working quite well and quick. :)

Now I am waiting for a friend to test the new shoutbox. I hope it will work, if more than one person make shouts. ;)

Re: Shoutbox and Custom Blocks in Portal

Reply #8
It's no longer working.  :-\  I collapsed the shoutbox, opened it again... and now it is the same as before: The "shoutbox-refresh" gets slow and new shouts are only shown, if I refresh the portal.




Re: Shoutbox and Custom Blocks in Portal

Reply #9
Can you give me an ID on your site an the site location, pm me the ID and password?  Hard to debug what I can't reproduce  :'(
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.