Skip to main content
Topic: Using Coppermine Gallery with ElkArte  (Read 1448 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Using Coppermine Gallery with ElkArte

How feasible is it ? Can we make it integrated ?

Re: Using Coppermine Gallery with ElkArte

Reply #1
I've Never used Coppermine, but based on the SMF bridge they have in their distribution, this should work. 

Place it in your coppermine/bridge directory from what I can tell and it should allow you to enter the gallery from your Elk login and visa versa I think when enabled.

TBH there is something about the sessions that seems off to me, but .... I guess its a start.

ETA: this is just a bridge not what I would call integration

Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Using Coppermine Gallery with ElkArte

Reply #2
Last day an user posed a requirement for gallery. I was just wondering if this would fill the gap. Coppermine Gallery is very popular by itself. I guess @radu81 might also be interested in this bridge. Thanks @Spuds .

Re: Using Coppermine Gallery with ElkArte

Reply #3
@MrCat , please check if this would suffice your needs. Thanks.

Re: Using Coppermine Gallery with ElkArte

Reply #4
I think it will be a mess with responsive templates, imho 
sorry for my bad english

Re: Using Coppermine Gallery with ElkArte

Reply #5
Sorry for dragging up an old topic, but I've been battling to bridge CPG 1.5 and the latest ElkArte using the above attached bridge script.

I've hit the age old problem that seems to surface with Coppermine and SMF bridging. I'm probably very rusty at all this. Been years since I last played around with forums, coppermine and all that!!

Anyway, first, fresh install of ElkArte.
Second, a fresh install of CPG1.5

The Coppermine install obviously need a separate admin name during the standalone installation. Once day, I uploaded the above bridge script and run through the bridging wizard. Done!!!

Back into newly installed Forum, added a link to the Gallery just to make life easier until I sort this out. Clicking on link takes me to gallery where I am not logged in. I click login, takes me back to the forum. Click gallery link, takes me back to gallery and so forth.

I cannot login to the gallery with my forum username. The gallery login just sends me back to the forum all the time.

I've disable local storage of cookies in the forum admin, I have enabled independent cookies as what many suggested over the years on the SMF forums who had similar issues.

I have a feeling it's almost there but I am doing something wrong.

Would it matter I have no domain pointed at the site as yet. I have both forums and gallery setup on a temp url http://ipipipip/~username type setup for now.

I was unsure if cookies/bridge would object to that? Something likely so simple if becoming an annoyance!

Thanks.

Re: Using Coppermine Gallery with ElkArte

Reply #6
Well, I'll be damned!!!!

Popped onto my laptop and gave it a try and the bridge works. Seems the desktop I do my work on needs a thorough cleaning of cookies etc!!

Will be back once I've cleared cookies on the desktop and tried again!

Re: Using Coppermine Gallery with ElkArte

Reply #7
@Spuds‍ have there been changes to prevent this working with 1.1.3?   :D

Re: Using Coppermine Gallery with ElkArte

Reply #8
From a quick look, I would say no.
Bugs creator.
Features destroyer.
Template killer.

Re: Using Coppermine Gallery with ElkArte

Reply #9
I don't have CM installed to do a real test, but looking at the code it should be fine as we did not change the login or members table in 1.1 from 1.0.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Using Coppermine Gallery with ElkArte

Reply #10
Hhmm...ok. I tried it with a working CPG 1.5 install. No joy. Perhaps this bridge was written for a CPG 1.4?


Re: Using Coppermine Gallery with ElkArte

Reply #12
It is using Coppermines 1.5 bridge so it should "just work" ... you have to enable it from within Coppermine if I recall correctly.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: Using Coppermine Gallery with ElkArte

Reply #13
It is using Coppermines 1.5 bridge so it should "just work" ... you have to enable it from within Coppermine if I recall correctly.

What does "just work" mean though? Bare bones functionality?

 

Re: Using Coppermine Gallery with ElkArte

Reply #14
Its a bridge application, here is what Coppermine says it can do ..... http://documentation.coppermine-gallery.net/en/bridging.htm 

Summary:
Quote
Coppermine can be integrated with other applications in terms of user management and sharing a common login on your overall website; this is what we call "bridging". It can create a more seamless end user experience, as your users will only have to register once; their login will stick both on the Coppermine pages as well as the pages you bridge with.
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.