Skip to main content
Topic: Warning level setting bug (Read 1401 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Warning level setting bug

Hi,

My forum I was a little confused  User Issue a Warning   level unknown  110 vaule

Go  Administration Center Core Features enable Post Moderation  and  set  Security and Moderation /  set moderation   vule

  



test


new installed elkarte


Core Features enable Warning System


go ""user    Issue a Warning ""  page

Level >= 35: All users posts will be moderated  (Post Moderation is not enable ?)

Core Features enable Post Moderation

""user    Issue a Warning ""  page

Level >= 110: All users posts will be moderated


Security and Moderation / Moderation

Warning level for post moderation  value: 0
sorry for my bad english

Re: Warning level setting bug

Reply #1
Darn, I left this one open on the "other" computer and missed that as well!
 emanuele is mad at himself >:(
Sorry for the late reply! :-[

Anyway, the issue is "just" that 110 is used when the option is not enabled (in that case post-moderation) to be sure it's not caught up by the warning system.

A possible fix is to replace in ProfileAccount.controller.php the block:
Code: [Select]
		// Work our the various levels.
$context['level_effects'] = array(
0 => $txt['profile_warning_effect_none'],
$modSettings['warning_watch'] => $txt['profile_warning_effect_watch'],
$modSettings['warning_moderate'] => $txt['profile_warning_effect_moderation'],
$modSettings['warning_mute'] => $txt['profile_warning_effect_mute'],
);
with:
Code: [Select]
		// Work our the various levels.
$context['level_effects'] = array(
0 => $txt['profile_warning_effect_none'],
);

foreach (array('watch', 'moderate', 'mute') as $status)
{
if ($modSettings['warning_' . $status] != 110)
{
$context['level_effects'][$modSettings['warning_' . $status]] = $txt['profile_warning_effect_' . $status];
}
}

Being a bug I'll move it to the appropriate board. ;)
Bugs creator.
Features destroyer.
Template killer.


Re: Warning level setting bug

Reply #3
Ugh, being there couldn't you fix the typo in the comment, too? "Work our" doesn't exist in English, "work out" can actually work out, lol.
~ SimplePortal Support Team ~