Skip to main content
Topic: PHP7.1 (Read 483 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

PHP7.1

Anybody using php7.1 for their EA forums? I have been testing this a lot lately and I find that it is definitely faster (double or more) than php5.6 as it claimed to be.[1].

I even tested it using multitenancy addon of which some of the sites are running under php7.1 like in https://elkarte.sch.my and some others are running under php5.6 like in https://x-skda.sch.my and the result is very much different and comparable.

As such I find EA is very much ready and works great with it.

Thank you for all developers who worked hard and smart in making EA works with this latest php version.
I used page creation speed as my tool to compare as is already available and I am too lazy to find and install any of the benchmark tools.

Re: PHP7.1

Reply #1
Definitely great news :)

Re: PHP7.1

Reply #2
PHP versionbench.phpmicro_bench.phpmandelbrot.php (3)
time% rel. gainabs. gaintime% rel. gainabs. gaintime% rel. gainabs. gain
5.0.58.650s--(1) failed--251.470s
5.1.63.718s57.02%2.327(1) failed--87.354s65.26%2.879
5.2.173.838s-3.23%2.254(1) failed--86.550s0.92%2.905
5.3.292.614s31.89%3.30919.469s--68.018s21.41%3.697
5.4.452.056s21.35%4.20710.300s47.10%(2)1.89033.610s50.59%7.482
5.5.381.995s2.97%4.33610.456s-1.51%1.86230.553s9.10%8.231
5.6.281.798s9.87%4.81110.243s2.04%1.90129.903s2.13%8.410
7.0.130.670s62.74%12.9104.056s60.40%4.80015.562s47.96%16.159
7.1.00.495s26.12%17.4753.327s17.97%5.5829.228s40.70%27.251
Squish squish. squish, squish, squish.
Find a bug,
Make a wish.

Re: PHP7.1

Reply #3
 niceee upgrade to 7.1 now :)

Re: PHP7.1

Reply #4
I would prefer to leave it optional for the time being though it is awesomely good and very fast so far.

Re: PHP7.1

Reply #5
Should I change my domians to PHP 7.1? Can I or can this cause problems with ElkArte?

Re: PHP7.1

Reply #6
This is quite an old thread. I am using php7.2 for my elkarte forum [1]now and so far is so good. ;)
like many others in here too

Re: PHP7.1

Reply #7
I had no problems switching to PHP 7.2.1.
Only one addon had to be adapted afterwards.
ElkArte version: 1.1.5 / Theme: BeSocial / PHP 7.2.7