Skip to main content
Topic: Cannot Get Vertification Captcha Working (Read 140 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Cannot Get Vertification Captcha Working

Good Morning!

I have installed Elkhart locally on Xampp (windows) to test prior to installing with my webhost. However, I am having trouble getting the Registration Verification Captcha to work (like it is on the Elkhart Community site).

Config -> Anti-Spam -> Require verification on registration page is enabled.

I also had the "Stop Spammer" Plugin installed, but uninstalled that in case it was having an impact. PHP GD library is installed.

There is obviously something I am missing here.....

Any help is appreciated.
Many thanks

P.S. Not going to be using Google's reCaptcha!

Re: Cannot Get Vertification Captcha Working

Reply #1
Further to my query, I have now installed ElkArte to a local Debian Linux virtual server to establish whether there was an issue not displaying the captcha under Xampp/Windows.

However, still no luck.

Not wanting to use Google's reCaptcha I am trying to install a similar CAPTCHA solution that ElkArte use on their registration screen (see attachment). I am now thinking that this is not inherent within ElkArts standard installation, but I cannot find a package that will provide this either.

I would appreciate any pointers.

Many thanks

Re: Cannot Get Vertification Captcha Working

Reply #2
Ok, so I have located the issue.

I downloaded and installed v1.1.5 and now have access to the CAPTCHA configuration in Configuration -> Security and Moderation -> Anti-Spam. The section "Configure Verification Methods" is completely missing in v1.1.6

Is this intentional, or a bug?

Cheers  ;)

Re: Cannot Get Vertification Captcha Working (Nearly!)

Reply #3
Following on...

Through my investigations this morning I have found that the loading of the captcha as a verification control, is missing in 1.1.6.

Adding the missing line, enables the captcha, as below:

File: sources/subs/VerificationControls.class.php - Lines 22 - 27

'known_verifications' array missing 'captcha'

Code: [Select]
function loadVerificationControls()
$known_verifications = array(

change to add captcha:
Code: [Select]
$known_verifications = array(

Captcha is now available and works with the following issues:
  • Captcha visually too small to easily read, both in the Admin section and on the Registration page. (see attached images).
  • 'Request another image' option on registration page seems to display the same Captcha...differently.

I have noticed also that the message in the admin panel is missing from themes/default/languages/english/ManageSettings.english.php

If it was intentional that graphic captcha be removed, then I would have suspected all of the code and javascript related to this to also be removed. This makes me think that maybe it was either temporary, or an error?

I cannot find any release notes for 1.1.6, so I can't check whether this is the case.

Also, I have checked sources/subs/Graphics.subs.php, with regard to the size of the captcha, to see if there are any differences between v1.1.5 and 1.1.6, but I cannot see any significant changes relating to font/images size.

I have both versions installed on the same server with the same PHP version & GD library version.

I am just trying to understand this and get captcha working in 1.1.6, with my extremely limited knowledge. The other concern that I would have is if the enabling of the captcha will break anything else, if of course it has been deliberately disabled.

Many thanks

(PHP 7.4.5, GD 2.2.4, Debian: 9.12)

Re: Cannot Get Vertification Captcha Working

Reply #4
Thanks for your report.
I don't have a clean 1.1.6 install to test it right now, but I will do it tonight, if I remember correctly installing the Google Capthca add-on will remove the default captcha. Are you sure you didn't install first the Google add-on?
sorry for my bad english

Re: Cannot Get Vertification Captcha Working

Reply #5
Thanks for your reply.

Yes I am sure! There is no way I want to use Google stuff.

With further work I seemed to have now fixed the sizing issue.

In 1.1.6 there is a new check in sources/subs/Graphics.subs.php on lines 1034-1035:

Code: [Select]
if (!checkGD())
   return false;

This code was not present in 1.1.5 and commenting this out (or removing it) fixes the sizing issue nicely.

As far as the refresh goes, this didn't work in 1.1.5. Instead of the captcha contents being changed (letters), these stay the same regardless and it is only the styling that changes.

For now, this is sufficient for me to work with. However, it would be nice to know whether this will break anything somewhere else - I guess time will tell. I will be going live this week! :-)

I hope this helps.


Re: Cannot Get Vertification Captcha Working

Reply #7
Sounds like a bug somewhere...
Okay, this evening no hair cut, but elk coding I guess.
Bugs creator.
Features destroyer.
Template killer.

Re: Cannot Get Vertification Captcha Working

Reply #8
No! Haircut first!  ;D


Re: Cannot Get Vertification Captcha Working

Reply #9
Well, no joy with the hairs, I couldn't confirm today for tomorrow, so I hope the spot of tomorrow will still be available tomorrow morning for tomorrow afternoon. xD

For now tried to fix the other issue, this goes to tomorrow morning.
Bugs creator.
Features destroyer.
Template killer.