Skip to main content
Topic: ElkArte 2.0 ? (Read 948 times) previous topic - next topic
0 Members and 1 Guest are viewing this topic.

Re: ElkArte 2.0 ?

Reply #15
https://semver.org/

Micro versions are generally supported for security fixes for at least a few months (that could be a year, for example) after the release of the next minor/major version.
So, you can expect 1.1.x to be supported for a while after 2.0 has been released.
Considering I'd like to have the 1st beta of 2.0 out by the end of the year, that would mean something like at least until 2022 I'd say.
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 2.0 ?

Reply #16
Considering I'd like to have the 1st beta of 2.0 out by the end of the year, that would mean something like at least until 2022 I'd say.
Yes, I wanted to know about it. Because I didn't find a topic about the state of development 2.0 here.
Community of forum owners on any forum engine (сообщество владельцев форумов на любом форумном движке) https://forumovod.ru

Re: ElkArte 2.0 ?

Reply #17
That's said but to note 1.0 is out of support quite early I'd say, so the best is to follow major upgrade to 2.0 once its stable version is released. Wait!? Do we have stable version here? :P. Yes, we do. ;)

Re: ElkArte 2.0 ?

Reply #18
Stable is an overrated word. :P
Bugs creator.
Features destroyer.
Template killer.



Re: ElkArte 2.0 ?

Reply #21
Then you need a staple (and a battery). Spoiler (click to show/hide)
Bugs creator.
Features destroyer.
Template killer.

Re: ElkArte 2.0 ?

Reply #22
Stable is an overrated word. :P
In SMF there is a thread about the nightly build.
https://www.simplemachines.org/community/index.php?topic=558451.0
Maybe someone here will also open such a topic about ElkArte 2.0?
Community of forum owners on any forum engine (сообщество владельцев форумов на любом форумном движке) https://forumovod.ru

 

Re: ElkArte 2.0 ?

Reply #23
Not really necessary.
SMF needs some moving around of files to create an install/upgrade package, for Elk, the install package is exactly the same as the file you can download from the repository, where it says "download zip":
[img[https://i.imgur.com/UvvMrOe.png[/img]
so, if you want a "nightly", just pick the file and be happy with it.
Anyway, TBH, if someone wants to try a development version and doesn't know how to create it, he is better not using a development version. Really. And I'm not ruling out help, I'm just saying if you want to try development you have to be ready to do some development.
Bugs creator.
Features destroyer.
Template killer.