Skip to main content
Recent Posts
1
Support / Re: ElkArte Mail Not Working
Last post by Steeley -
OK Denis..

1 -Have you created an smtp email account on your host's email server?

2- Have you created an account-identity in your own email client to use that account, (Outlook, MS Mail, Pegasus Mail,, Spark, Canary Mail, whatever.. NOT your host's webmail software), and sent and received email using it through that account to verify the account is in fact accessible, credentialed and functioning properly?

If yes, to both questions now we can proceed to make ElkArte do the same thing your email client is doing.. If you haven't done both of those yet, then do that, make sure you can establish a functioning configuration before asking ElkArte to use it.


Edit: regarding the error message you just posted "Messages with multiple addresses in From: header are\n550-5.7.1 not accepted"
It looks like whatever is trying to use that account to send mail (ElkArte?) is not configured properly.. I suspect you have some latent configuration stuff for Sendgrid still present (maybe in the Hosts email account set up??), but it also may be that you have your ElkArte Sender information set up to include your subdomain (which is being misinterpreted as a separate From address perhaps(?), or the name of your forum as a Sender has a comma or some other typo in it making it appear you have multiple senders.  But first, as I noted above, do #1 and #2 above so we know for sure where the real problem actually is.
 
2
Support / Re: Email Templates Bugged Problem
Last post by Denis M. -
Quote from: Spuds –
Quote from: Denis M. – he Email templates are awfully looking, not sure if they are supposed to look like this, if it is then it's okay I can handle the eyesore ?
Quote from: Steeley – then those cryptified links inserted by Sendgrid in the outbound email (necessary to get back to your website) won't be necessary.
I had no idea that sendgrid would rewrite the links, those are crazy looking. 

Its possible (with several manual edits etc) that instead of having full https:\\www.tld.com\bla links that you could strip off the https:\\ and then they would not be modified, of course they would not be clickable in the email, the user would have to cut / paste which is a horrible experience. 

Seems like if using sendgrid you just have to live with that, its the price you pay for "free"


Yeah that is not an option unfortunately   :rolleyes:  , I have decided to go with my hosting providers email service and just avoid being blocked, they block all emails that are like a ''newsletter'' with the same email being sent to multiple email adresses, that's the only restriction, so I will just be starting off with email notifications being turned down to the max, registration/reset password emails etc. will work fine though

But unfortunately now when I reverted back to the PHP Default email option in Mail Settings the mail doesnt go through and just dissapears ? I've made a new post about the problem, keep in mind theres no error log information I could use to go deeper on the subject, so now I am completely lost  :cry:

ElkArte Mail Not Working
3
Support / Re: Email Templates Bugged Problem
Last post by Spuds -
Quote from: Denis M. – he Email templates are awfully looking, not sure if they are supposed to look like this, if it is then it's okay I can handle the eyesore ?
Quote from: Steeley – then those cryptified links inserted by Sendgrid in the outbound email (necessary to get back to your website) won't be necessary.
I had no idea that sendgrid would rewrite the links, those are crazy looking. 

Its possible (with several manual edits etc) that instead of having full https:\\www.tld.com\bla links that you could strip off the https:\\ and then they would not be modified, of course they would not be clickable in the email, the user would have to cut / paste which is a horrible experience. 

Seems like if using sendgrid you just have to live with that, its the price you pay for "free"
4
Support / Re: Email Templates Bugged Problem
Last post by Denis M. -
Quote from: Steeley –
Quote from: Denis M. – Or should I just leave it on PHP default and contact my hosting provider for further assistance in setting up the email, I will be contacting my hosting provider as soon as I get a reply here!

Yes indeed.. don't try to address hypothetical problems unless and until they actually materialize. 

I responded in more detail in the Sendgrid thread..  but yea, trust ElkArte to work, set the email accounts as basic SMTP like any other email account,  Identify in EA which accounts are for which purpose, configure EA to access them, and let it fly..

In the mean time, end this thread since it's an artifact of the other Sendgrid issue, and then abandon Sendgrid, and if you run into issues with native operation, open a new thread about those issues if you and your host can't resolve it and we'll be all over it with you.


Okay @Steeley I listened to the advice and heres my new post about the subject Mail Completely Not Working Now
5
Support / ElkArte Mail Not Working
Last post by Denis M. -
Greetings community !

After having several difficulties in setting up SendGrid SMTP, just to note that their mail system does not support HTML codes provided by ElkArte and it makes the emails look horrible...

On @Steeley 's suggestion I reverted back to the default PHP mail system and deleted the SendGrid DNS edits, but unfortunately now the emails do not go through, there is nothing in the Error Log which could help me elaborate on the subject the emails after being sent from the email queue just simply vanish into oblivion.

Any suggestions would be great at this point! Thanks in advance !

Update: I found an error log related to email on my hosting provider and this is what it states:

TLS_AES_256_GCM_SHA384:256 CV=yes: SMTP error from remote mail server after end of data: 550-5.7.1 [37.27.123.108] Messages with multiple addresses in From: header are\n550-5.7.1 not accepted. For more information, go to\n550-5.7.1 https://support.google.com/mail/?p=RfcMessageNonCompliant and review\n550 5.7.1 RFC 5322 specifications. 2adb3069b0e04-52ef0799968si250273e87.367 - gsmtp

Been looking for a way to check out the $headers = 'From: , but cant find it anywhere and It shouldn't even be giving this error since theres only one address as the webmaster mail ?
6
Support / Re: Email Templates Bugged Problem
Last post by Steeley -
Quote from: Denis M. – Or should I just leave it on PHP default and contact my hosting provider for further assistance in setting up the email, I will be contacting my hosting provider as soon as I get a reply here!

Yes indeed.. don't try to address hypothetical problems unless and until they actually materialize. 

I responded in more detail in the Sendgrid thread..  but yea, trust ElkArte to work, set the email accounts as basic SMTP like any other email account,  Identify in EA which accounts are for which purpose, configure EA to access them, and let it fly..

In the mean time, end this thread since it's an artifact of the other Sendgrid issue, and then abandon Sendgrid, and if you run into issues with native operation, open a new thread about those issues if you and your host can't resolve it and we'll be all over it with you.

 
7
Support / Re: Setting up SMTP Mailing service
Last post by Steeley -
Set up the  email account(s) for your foum on your host like you would any other type of email account.

You will want at least an account for elkArte to use to send and receive emails (copies/notifications of forum posts, newsletters, whatever..), and one for webmaster communications. If you are going to allow  Post By Email, that will be a different set of issues, let's crawl before trying to stand and run..

Now, go into ElkaArte Admin and configure communications to use each account.

That's all you have to do.

If it doesn't work right, or at all, then debug the EA configuration, and/or figure out what's going on with the host SMTP email handling.

It's been more than 5 years now since I set up email communications with ElkArte so I'm going to have to think/look back, but as I recall, this part was very simple.  (What took some trickery was the fact that I have about 20 "boards" and PBE, and some fun cron jobs running to make that work). I think I had to work with spuds a bit to resolve some legacy issues in the php sendmail (EA v 1.16), but those have been corrected in later releases..

The only time I've ever had any issues with sending and receiving email with EA is when my host's email servers were "updated " and the new configurations broke the process, that my host had to go back in and fix..
So, make sure you have your own separate "user" (in addition to admin or "webmaster" account) and email addy for it, so you can "test" what your users will see, but more important, see when stuff just mysteriously stops working and know your host just did something to the email server!

Forget Sendgrid, don't worry about anything re: php unless your testing shows there's a problem there, and if you can't figure that out, come to us and we can focus on solving the problem rather than finding a suitable bandaid or work around that nobody has ever used before..

Your host's email doesn't know or care where on the server domain EA resides, and EA doesn't care where it is either  - mydomain.com/forum, or forum.mydomain.com/forum, it doesn't matter when it comes to email handling. EA just needs to know the email account addy, and credentialing to get into it. The host's email has no idea where the account access attempt is coming from(*), just needs to know it had the right credentialing. 

*exception: there's some handshaking and checks that now goes on between the SMTP email server and the accessing "client" (EA in this case) for security purposes, but that should be moot if EA is on the same box as the server - there should be no 'security 'handshaking" you have to worry about in that situation.

What I recommend is to close down this thread, and the Email template thread, then start over - reconfigure your installation for local host email, and create a new email thread if you run into problems, based on resolving the problem, not trying to configure the workaround attempt. Trust EA to work as intended "out of the box" and don't try to deal with theoretical problems unless you actually encounter them. If they do manifest, then fix it, rather than try to sidestep it.

Oh, and unless there's a very good reason to operate in a subdomain, don't complicate things unnecessarily.

[EDIT: I believe C-Panel softaculous has listserve support/ties at the server level, which may (or may not) be an easier/more elegant  solution if your forum becomes so successful it outgrows your host's email volume tolerance. But worry about dealing with that problem only if you actually encounter it. 
8
Support / Re: Email Templates Bugged Problem
Last post by Denis M. -
Quote from: Steeley –
Quote from: Denis M. – So if anyone has any ideas on what I could do to fix this up it would help out a lot !

Yep - get rid of Sendgrid and use your host -  then those cryptified links inserted by Sendgrid in the outbound email (necessary to get back to your website) won't be necessary.

This is what it should look like...

[attach align=left]10738[/attach]

Greetings Steeley! and you are right ! I am using SendGrid only because mass emailing through my host will get me blocked as they advised me, but since I wont be having like hundreds of emails being sent and the forums have only 1 member at the current moment which is me I cannot expect a lot of emails going through!

You offer a good point, but how would one go on with setting up the mail system so it doesn't go through PHP ? or does it need to go through PHP if I decide to use my hosting provider as the email server ?

I am providing a screenshot of my hosting mailbox information below, since these mailing systems confuse me a bit, should this be the information entered for SMTP ?

smtp+manual+configuration+settings.jpg

Thanks for all the advice and help ! It means a lot really !

Or should I just leave it on PHP default and contact my hosting provider for further assistance in setting up the email, I will be contacting my hosting provider as soon as I get a reply here!
9
Support / Re: Setting up SMTP Mailing service
Last post by Denis M. -
Quote from: Steeley –
Quote from: Steeley – I'm a big fan of "KISS" ... the fewer things that can go wrong, will usually result in fewer things going wrong.

As you discovered in the registration email you got and reported here..  I'm strongly suspecting that your decision to use Sendgrid instead of working with your host to resolve whatever problem you were having was made in haste, and, as you have now discovered, not the most elegant of solutions. I dare say it's only going to get worse.. (much worse) when you see what the forum emails look like

Below is an email copy of ahrasis earlier post.. what is circled in red is what Sendgrid is going to modify and 'cryptify'...

[attach width=300 align=left]10742[/attach]

As I noted over in that other thread - you need to get rid of Sendgrid and fix the issue with your host email system (if the issue still exists..)


Well thats an amazing elaboration Steeley! and you are right ! I am using SendGrid only because mass emailing through my host will get me blocked as they advised me, but since I wont be having like hundreds of emails being sent and the forums have only 1 member at the current moment which is me I cannot expect a lot of emails going through!

You offer a good point, but how would one go on with setting up the mail system so it doesn't go through PHP ? or does it need to go through PHP if I decide to use my hosting provider as the email server ?

I am providing a screenshot of my hosting mailbox information below, since these mailing systems confuse me a bit, should this be the information entered for SMTP ?

smtp+manual+configuration+settings.jpg


Thanks for the advice ! I started another Topic about the HTML problems with emails Ill be replying Here
10
Support / Re: Setting up SMTP Mailing service
Last post by Steeley -
Quote from: Steeley – I'm a big fan of "KISS" ... the fewer things that can go wrong, will usually result in fewer things going wrong.

As you discovered in the registration email you got and reported here..  I'm strongly suspecting that your decision to use Sendgrid instead of working with your host to resolve whatever problem you were having was made in haste, and, as you have now discovered, not the most elegant of solutions. I dare say it's only going to get worse.. (much worse) when you see what the forum emails look like

Below is an email copy of ahrasis earlier post.. what is circled in red is what Sendgrid is going to modify and 'cryptify'...

show.jpg

As I noted over in that other thread - you need to get rid of Sendgrid and fix the issue with your host email system (if the issue still exists..)