Skip to main content
Recent Posts
Addons / Re: [ADDON] ElkArte Ajax Chat
Last post by Spuds -
Quote from: Vector – When installing the latest version of the chat on the forum version 1.1.9, it gives an error - vsprintf(): Argument #2 ($values) must be of type array, string given
That seems like a PHP 8 error.

Doing a quick look at the addon, it utilizes AJAX-Chat (by Blueimp) which I did find on GitHub.  However it has not been updated in 7 years, so its unlikely to work with PHP 8. 

This addon is really a wrapper around that program, so until the AJAX-Chat author decides to update that code, this addon is not going to work.  Perhaps there is a fork of that project that has been updated that could be used here, I did not look into that.
Chit Chat / Re: Slowly catching up
Last post by Spuds -
Quote from: Steeley – BTW, is that Zipply Fiber? They've been sending me stuff in the mail, salesmen to my door, etc. for months.
Ben Lomand Connect .. They had applied for a grant to build out undeserved areas, and this was one of those areas.

That took some doing as the current internet in the area is DSL via Frontier Communications.  Frontier had marked this area as 25Mb on the FCC maps, so as far as the Goberment was concerned, the area was served.  That FCC map has these large blocks, not sure how they arrived at the boundaries, but as long as a single household in a block could get 25Mb, then the entire area was considered served.

To override that, folks had to write in, submit speed test reports, etc to our local gov, basically showing they could not get those speeds.  I could not submit an official report as when I moved here, Frontier had no taps available and would not provide a drop!  Honestly that was fine as we are so far away from the central DSL building that my neighbors only get 4-6Mb ... 8-12Mb if you do a bonded pair at twice the cost.  6Mb is ridiculous,  but saying 25Mb is high speed is weak gravy !  

After the petitions / data was collected, the FCC was informed of their bogus maps, who in turn gave the current provider time to respond / correct.  The wheels of progress turn slow.

All told, it took 4 years of on/off effort by the local gov, ben lomand, and all the households, to get the area marked as under served and eligible for a grant.  So far all that has been done is install the main fiber line on the street (its all underground).  Although it was fun to watch those horizontal directional boring machines work, they still make a mess of your lawn.   Still 6 months to go before they splice all the fiber / connect the homes but hey its a start.  At least with my setup I can get 200Mb but has a wireless latency and I'm paying to way much ... but I can stream !
Chit Chat / Re: Slowly catching up
Last post by Steeley -
It's the season.

My desktop is a Dell Inspiron 580  (it's a teenager now), 8GB, Intel i3 dual core 3.2Gb, 1TB partitioned drive with an 8TB backup and a 500gb slave, dual dvd drives (and I have a standby Inspiron 580 chassis and motherboard if this one goes nipples up..)  Dual 25" monitors.
This morning the oddest thing.. I suddenly lost internet access, although I still had full wired ethernet LAN. It was the only box on the LAN that couldn't access the Inet. OMG, I panicked.  Don't know if it's a driver or a hardware fail... no idea how to isolate that,  but since  I had a USB ethernet dongle, it restored that functionality, A new ethernet card (and a wireless card) should be arriving tomorrow.
Not as dramatic a presentation but then I'm old and retired and it doesn't take much to crush my soul.. I break a shoelace and I'll likely just go back to bed and call it a day. :sob:

BTW, is that Zipply Fiber? They've been sending me stuff in the mail, salesmen to my door, etc. for months..  Yea, I don't want to replace my hubs either. (I never thought 100mps would be considered too slow..)

Chit Chat / Slowly catching up
Last post by Spuds -
Sorry I've not been around these last few weeks  :zipper_mouth:   What's been keeping me busy, well where to start !

First ... l I ran out of gas, I had a flat tire, I did not have enough money for cab fare, my tux did not come back from the cleaners, an old friend came in from out of town, someone stole my car, there was an earthquake, a terrible flood, locusts, ... It was not my fault!

Really?  OK

1) My NAS was running out of space and I needed to change out the disks with larger ones.  My old ZFS array was done with (ashift 9) for 512k and the new (old) drives I purchased were 4k drives (ashift 12).  Originally I was going to update the array drive by drive, rebuild, expand ... slow but no down time.  However there is no way to move a 512k to 4k pool "doing it that way".  So instead I created a new pool (read drives stacked on my desktop, wired back to the controller) and then did zfs send | zfs recv followed by zfs export | zfs import.

--> TLDR: the NAS was offline for a bit :P  I did get a smoking deal on the SAS drives via Ebay, less then a year old, low low hours.

2) NAS back on line, I decided I no longer wanted to run the docker ZFS storage driver, for me it was just messy.  I moved it back "standard" and only leave the volumes on my ZFS array.  When using docker ZFS storage it creates each container file system layers as ZFS datasets, many many many datasets, which makes normal server management ugly IMO. 

--> TLDR: A bit more down time as I use docker containers for all my Dev work and the change was not without problems.

3) Leaves, lots and lots of leaves, oak, maple, poplar, hickory .... now all mulched and waiting for springs garden.

--> TLDR: Leaf-ageddon .. Leaf-naddo

4) New laptop :D ... I do a majority of my work on a laptop and the previous one was not a favorite of mine (read the product line had been severely discontented.  The previous version was nice, but they maximized profit over a decent product.  Now the new laptop is flat out awesome.
When I set it up, I decided to rebuild it from scratch vs clone the old to new (to much clone baggage)  That took a few days to get everything installed, updated, licensing transferred, settings, etc etc  ... Got it all working great, oh whats that a driver update for the display, I must have this .. bricked the OS, recovery failed, ZOMG ....  Had to start off all over again, still not done LOL

--> TLDR: Don't do display driver updates from Intel or great pain awaits you :head_bandage: !

5) Holiday

--> TLDR: Family, still recovering  :shocked:

6) Hey what is that truck doing on my street ... installing fiber you say  :cool:   I'm currently on 50/50 balanced Starlink / ATT wireless, expensive yes, but the only way to get passable speeds out here in the 'sticks'.  The new Fiber will be 1Gb up and down, sweet.  My current (now old) gateway only supports 1Gb total, not 1Gb each direction.  So I upgraded that gateway!  Yup, a few more days down while I replaced the gateway, and hey since the new laptop is WiFi 6, update the access point(s) as well.  Sold the old (7 year old) equipment on Ebay.  I will say I tripled my WIFI speed going to the NAS for big files.

--> TLDR: New infrastructure destroys lawns !

So basically all my free time for Dev FOSS has been consumed by the above.   Its going to take me a while to catch up here and elsewhere ... Sorry !
Support / Re: After changing the PHP version, thousands of time error messages are reported
Last post by Steeley -
Depending on how adept you are with php, the suggestions in this may help @Mrs. Chaos ..

...or at least kudos for the heads up  {weak grin}

Then again, rolling back to 8.0 until a patch is in may be the easiest option..

[Update: v1.1.9 supports php 8.x according to the gurus, @Spuds can confirm whether that extends to strftime/gmstrftime going forward to php 9.0 eliminating it completely, if you wish confirmation before choosing that option..]