Skip to main content
Recent Posts
Chit Chat / Slowly catching up
Last post by Spuds -
Sorry I've not been around these last few weeks  :zipper_mouth:   What's been keeping me busy, well where to start !

First ... l I ran out of gas, I had a flat tire, I did not have enough money for cab fare, my tux did not come back from the cleaners, an old friend came in from out of town, someone stole my car, there was an earthquake, a terrible flood, locusts, ... It was not my fault!

Really?  OK

1) My NAS was running out of space and I needed to change out the disks with larger ones.  My old ZFS array was done with (ashift 9) for 512k and the new (old) drives I purchased were 4k drives (ashift 12).  Originally I was going to update the array drive by drive, rebuild, expand ... slow by no down time.  However there is no way to move a 512k to 4k pool "doing it that way".  So instead I created a new pool (read drives stacked on my desktop, wired back to the controller) and then did zfs send | zfs recv followed by zfs export | zfs import.

--> TLDR: the NAS was offline for a bit :P  I did get a smoking deal on the SAS drives via Ebay, less then a year old, low low hours.

2) NAS back on line, I decided I no longer wanted to run the docker ZFS storage driver, for me it was just messy.  I moved it back "standard" and only leave the volumes on my ZFS array.  When using ZFS storage it creates container file system layers as ZFS datasets, many many many datasets, which makes normal server management ugly IMO. 

--> TLDR: A bit more down time as I use docker containers for all my Dev work and the change was not without problems.

3) Leaves, lots and lots of leaves, oak, maple, poplar, hickory .... now all mulched and waiting for springs garden.

--> TLDR: Leaf-ageddon .. Leaf-naddo

4) New laptop :D ... I do a majority of my work on a laptop and the previous one was not a favorite of mine (read the product line had been severely discontented.  The previous version was nice, by they maximized profit over a decent product on the one I had.  Now the new laptop is flat out awesome.
When I set it up I decided to rebuild it from scratch vs clone old to new (to much clone baggage)  That took a few days to get everything installed, updated, licensing transferred, settings, etc etc  ... Got it all working great, oh whats that a driver update for the display, I must have this .. bricked the OS, recovery failed, ZOMG ....  Finally had to start off all over again, still not done LOL

--> TLDR: Don't do display driver updates from Intel or great pain awaits you :head_bandage: !

5) Holiday

--> TLDR: Family, still recovering  :shocked:

6) Hey what is that truck doing on my street ... installing fiber you say  :cool:   I'm currently on 50/50 balanced Starlink / ATT wireless, expensive yes, but the only way to get passable speeds out here in the 'sticks'.  The new Fiber will be 1Gb up and down, sweet.  But my current gateway only supports 1Gb total, not 1Gb each direction.  So I need to upgrade that gateway!  Yup, a few more days down while I replaced the gateway, and hey since the new laptop is wifi 6, update the access point(s) as well.  Sold the old (7 year old) equipment on Ebay.  I will say I tripled my WIFI speed going to the NAS for big files.

--> TLDR: New infrastructure destroys lawns !

So basically all my free time for Dev FOSS has been consumed by the above.   Its going to take me a while to catch up here and elsewhere ... Sorry !
Support / Re: After changing the PHP version, thousands of time error messages are reported
Last post by Steeley -
Depending on how adept you are with php, the suggestions in this may help @Mrs. Chaos ..

...or at least kudos for the heads up  {weak grin}

Then again, rolling back to 8.0 until a patch is in may be the easiest option..

[Update: v1.1.9 supports php 8.x according to the gurus, @Spuds can confirm whether that extends to strftime/gmstrftime going forward to php 9.0 eliminating it completely, if you wish confirmation before choosing that option..]
Support / After changing the PHP version, thousands of time error messages are reported
Last post by Mrs. Chaos -

for two days now, thousands of time error messages have been created daily in the forum. I have not changed anything in the forum and the 24-hour format is still set.
However, two days ago I changed the PHP version of all my domains from 8.0 to 8.1 (8.1.22) and therefore I suspect that this has something to do with it.

What do I have to change in the subs.php and logging.php codes to make the errors disappear? Or does something have to be changed somewhere in the admin centre because of PHP 8.1 ?
Attached are screenshots of all error messages.

Kind regards
Custom Themes / Re: [Theme] Separation
Last post by Burke Knight -
Is there a way to fix the menu so it's more responsive?
Right now, the drop-down goes left to right, where most gets cut off on mobile.
Is there a way to make it up-down instead?
Addons / Re: [BBCODE] HTML tag
Last post by Vector -
I installed this addon so that I could add an html tag, but when editing a message it gives an error and it is impossible to edit the message. /home/----/ I hid the full address

HTMLBBC::unpreparse_code(): Argument #3 ($i) must be passed by reference, value given
PHP Fatal error: Uncaught exception 'ErrorException' with message 'HTMLBBC::unpreparse_code(): Argument #3 ($i) must be passed by reference, value given' in /home/----/public_html/sources/Hooks.class.php:110
Stack trace:
#0 (): error_handler(integer, string, string, integer)
#1 /home/----/public_html/sources/Hooks.class.php(110): call_user_func_array(array, array)
#2 /home/----/public_html/sources/Subs.php(1434): hook(string, array)
#3 /home/----/sources/subs/BBC/PreparseCode.php(720): call_integration_hook(string, array)
#4 /home/----/public_html/sources/controllers/Post.controller.php(461): un_preparsecode(string)
#5 /home/----/public_html/sources/controllers/Post.controller.php(114): _generating_message()
#6 /home/----/public_html/sources/controllers/Post.controller.php(70): action_post()
#7 /home/----/public_html/sources/SiteDispatcher.class.php(364): action_index()
#8 /home/----/public_html/index.php(136): dispatch()
#9 /home/----/public_html/index.php(66): elk_main()
#10 {main}
thrown in /home/-----/public_html/sources/Hooks.class.php on line 110