Skip to main content
Recent Posts
31
Support / Re: Setting up SMTP Mailing service
Last post by Steeley -
Keep your notes, because at some point when it stops working, you'll want to get things configured "correctly" to be sure the problem isn't related to the "misconfiguration" that is "working anyway" at the moment..
32
Support / Re: Using Gmail for the admin account?
Last post by Steeley -
Quote from: Hometutor –
Thank you, I thought I'd read something about this

"Less secure apps & your Google Account
Starting on September 30, 2024, less secure apps, third-party apps, or devices that have you sign in with only your username and password will no longer be supported for Google Workspace accounts. For exact dates, visit Google Workspace Updates. To continue to use a specific app with your Google Account, you’ll need to use a more secure type of access that doesn’t share password data. Learn how to use Sign in with Google.

If an app or site doesn’t meet our security standards, Google might block anyone who’s trying to sign in to your account from it. Less secure apps can make it easier for hackers to get in to your account, so blocking sign-ins from these apps helps keep your account safe.'


As what I feared...  :nerd:

Cool, so GOOGLE just forbids anyone from signing into a Gmail account unless they are using a "GOOGLE-specification" OAUTH2-compliant secure client...    :rolleyes:
That wouldn't be so bad if they used the same "secure" criteria as everyone else, but nooo... [quote OUR Security Standards unquote] they're GOOGLE, your client must meet their unique standards, in addition to everyone else's.

So Google joins Apple in becoming The Platform For The Rest Of Them[TM] (You must use only zee programz we approve and allow!) :zany_face:

BTW, I believe this will also apply to email you want to send to a Gmail account, not just log into a gmail account.. if the email didn't originate from an approved client, off to bit heaven it will go.. (I do not think SPF/DKIM/TLS by itself is going to be sufficient for email to Google , if now, certainly not for long .. )

For the record, EA works fine and will continue to work fine if your own host's mailserver supplies SPF or DKIM (and most should, and do) - since your host's mailserver knows the mail is coming off its own box.. I certainly wouldn't want to press for EA to dive into that black hole and try to accommodate that function on its own.
33
Support / Re: Easiest way to find certain strings for ElkArte translation editing ?
Last post by Spuds -
There are several language packs available (abet in various levels of completion) https://translations.elkarte.net/  and transifex is the tool used to do the translations and from there updates are packaged nightly.  I'm not sure if that offers a search function on the strings.

If you can't find a specific string, be sure to look in the index.english.php file (of course this will be index.yourLanguage.php) as that file contains common words that are used in various other stings (concatenation and sometimes proper plural usage) Not saying that is a great thing, just noting that is what was done in a few places.
34
Support / Re: News ticker header not ticking ?
Last post by Spuds -
This appears to be a regression:bug:

To fix this you will need to edit the index.template.php file for your theme(s).  In that file you will find a function function template_news_fader  then find the following

Code: (find) [Select]
	addInlineJavascript('
document.addEventListener("DOMContentLoaded", () => {
if (typeof Elk_NewsFader !== \'undefined\') {
$(\'#elkFadeScroller\').Elk_NewsFader(' . (empty($settings['newsfader_time']) ? '' : '{\'iFadeDelay\': ' . $settings['newsfader_time'] . '}') . ');
}
});', true);
and replace it with this.
Code: (replace) [Select]
	addInlineJavascript('
document.addEventListener("DOMContentLoaded", () => {
if (typeof $.fn.Elk_NewsFader !== \'undefined\') {
$(\'#elkFadeScroller\').Elk_NewsFader(' . (empty($settings['newsfader_time']) ? '' : '{\'iFadeDelay\': ' . $settings['newsfader_time'] . '}') . ');
}
});', true);

All we are doing is adding $.fn. in front of Elk_NewsFader .... the error is that Elk_NewsFader is a jquery function so we need to look for it in the jquery space.
35
Support / Re: Gruesome Theme Help, Changing the Logo Styling
Last post by Spuds -
Make sure you do not have Minify Javascript and CSS files enabled under Admin->Features->General  and at the same location click the clear hive cache  If you were using this feature the system may not see the file being updated and serve the old one.  Best to leave that feature off until you are done with changes.

You should not be editing index.css, if you want to effect changes to that, make them in the custom.css Yes both will work but you are going to make yourself mental if you make overwriting changes in to many places.  If you want to make changes to the colors, I would recommend adding a custom_dark.css to the gruesome\_dark directory and add your changes there.

Validate the file was updated on the server, your control panel should have a file explorer or just use ftp or whatever.  Just want to ensure that the file was actually modified.

If your browser/site cache has been cleared the only other thing I can think of is that the site is running pagespeed or some other web server accelerator is using an old copy.

36
Support / Re: Gruesome Theme Help, Changing the Logo Styling
Last post by Denis M. -
Quote from: Spuds – Whenever you make CSS changes, you must always clear your browser cache, for that site, to:eyes:the changes, otherwise it will use the cached version from your browser.

Depending you what browser and OS ... its should be on of these
CTRL + F5 (win) or CMD + Shift + R (mac) <- chrome
CTRL + F (win or CTRL + Shift + R (win) or CMD + Shift + R (mac)  <- Firefox

The way I set up Gruesome was using a custom.css file ... its in the CSS directory and is used to over-ride the base index.css  as it is the last CSS file to load for a theme's structure.   The Gruesome structure is not much different than a default ELK one, so using an override file was easiest.

The colors are all in /css/_dark/index_dark.css.  Here there were many changes to the default Elk _light css file so I chose not to use an override file but instead make the changes in the base_dark file.  I could have used a custom_dark.css file in /css/_dark and is a good way to go if you are only making a few edits.

The sequence of files being loaded is as follows.

Code: [Select]
index.css (in the /CSS directory, holds the page layout/structure and no eye candy/colors)
custom.css (for gruesome, this holds all the overrides I did to the default theme)
index_varient.css (in this case index_dark.css, this is the color / eye candy stuff. 
custom_dark.css (not used in this case)
The code in the last file takes precedence, unless you used !important in earlier files, or used more specific selectors ...

Hey Spuds ! Just to check in, I somehow got some parts of my code edits to work but I am still having problems even when using !important tag, regarding the part where you said ''The code in the last file takes precedence'' Did you mean the ''index_varient.css'' ?

The code changes perfectly in the preview window but I am pretty lost why it didnt change in the front end, even tried purging the cache, any further advice would be much appreciated !

EDIT: Just to further note that Inspect element shows the code being pulled from index.css and even after editing and even adding the !important tag directly into that CSS file, nothing happens , even after purging the backend cache and my browser cache

EDIT: Thought it would be a good idea to explain what I am currently trying to edit , namely I am trying to hide ''#collapse_button'' with ''display: none;'' , as I said above it works perfectly in the preview tab but gives no changes in the frontend , it's a nice function to have but currently I want to hide it, though I am thinking about removing it completely as a solution :laugh:

Added a screenshot for refference:
upshrink+display+none.jpg


Just an edit I finally got it working, have no Idea how it magically updated after waiting for a while, could use some more info on the refresh rate of the CSS updates or how is this possible ?
37
Support / News ticker header not ticking ?
Last post by Denis M. -
Hello there community !

I have noticed that the news ticker on my forums is not ticking, it only changes sometimes when the page is refreshed ? Is this a special function or addon ?

Thanks in advance!
38
Support / Easiest way to find certain strings for ElkArte translation editing ?
Last post by Denis M. -
Hello there community!

Since I am in the process of forum localization regarding the translation of certain strings (I was shocked at how many strings are missing  :huh: ) I am in need of a bit of advice/help on what would be the easiest way of finding certain strings that need to be translated, since the only way I currently understand is going through page by page and using the built in browser search function  :embarrassed:

The problem is I sometimes cant find the particular strings even if I am looking for a registration string in the registration string page, keep in mind that I do not need everything translated eg. the admin panel and backend and I would like to publish the forums as soon as possible so translating everything is still not an option even though I will be either doing that or hiring extra help for finishing that task, for starters I am ready to launch the forums with minor issues in translation that are not that obvious and having a special board where users could submit un-translated strings.

But for now I just need a bit of help getting these two strings translated, the registration page has a 'Sign up to receive important site news by email:' string which is nowhere to be found on the ->Registration string page

Also there is a string during login next to the OpenID field with a question mark supposed to open a help window which shows an error

Here are the screenshots for better refference:
Forum+Open+ID+help+text+language+translation.jpg
forum+sign+up+to+recieve+news+by+email+language+translation.jpg

Also after translating most of the strings that weren't translated what would be the correct way of submitting an improved language pack for my native language ? Does that need to go through GitHub ? I think it would be useful for future ElkArtians in their quest on building a forum, since I am already translating I mean why not contribute ?  :smiley:

Thanks in advance!
39
Support / Re: Can't change my forum profile here on ElkBoards ?
Last post by Denis M. -
Quote from: Spuds –
Quote from: Denis M. – Sure thing Spuds ! Ill be checking back frequently, still no changes though
This should be fixed now, give it a try.

It was a new bug, kind of interesting really.  On the profile options form, there are some hidden input fields, mostly around the various avatar selections.  Anyway one of those had a type="url" which triggers the browser to validate that the entered value is a valid url.  But since this is an optional field, if left blank, the form simply fails to validate (via the browser) and never gets submitted.


Fixed ! Thank you very much Spuds ! Great job buddy !
40
Support / Re: Setting up SMTP Mailing service
Last post by Denis M. -
Quote from: Spuds – Thank you for letting us know that it is solved !! Glad its working.



Thanks for the efforts ! Support means a lot when having a hard time !

Quote from: ahrasis –
Quote from: Denis M. – main domain instead of the subdomain


We may get confused of this some times since both could be FQDN, so that is good to know.

Another question, did you also try to leave it blank instead of filling it and did that work?


The funny thing is that my ''SMTP Client'' field is actually setup wrong and it's still working ! I have my email address customaddress@forums.mydomain.cc in there but it still sends it through from the admin@forums.mydomain.cc email address so that's a bit funny if I understand correctly a domain name should be in there  :laugh:  but I guess I'll need to delete the admin@forums.mydomain.cc address from the SendGrid verified senders dashboard, but I'm currently too happy that it actually works and wont be touching anything so I don't ruin this happy feeling I got, well at least until I get a separate domain setup for the forums  :cheesy:

I actually just verified my main domain ''mydomain.cc'' in the SendGrid backend and it went through, didn't even notice the SMTP Client field was wrong, I'm not sure how this is working but as they say ''Do not question happiness'' :laugh: